Safer Connection with Newer Versions of TLS

Safer Connection with Newer Versions of TLS

From 3 March 2019, we are disabling the cryptographic protocol TLS 1.0 on all memoQ cloud instances and memoQ hosted servers in order to switch to TLS 1.1        or higher, as suggested by the PCI Council. 

  • 26 February 2019
  • by The memoQ Team
Read more